View Full Version : vidtogfx failure

08-24-2003, 09:47 AM

I just got the ML alpha built, and installed on my RH 9 box.

I got vidtogfx to compile, however when i run it - giving in my bt878 as the device name - i'm confronted with:

"Couldn't get controls on path"

Looking at the source i'm presuming the thing is failing from mlget/setcontrols - and i've tried giving in a PAL or NTSC parameter into the program...

Any clues?



[ August 25, 2003: Message edited by: caspar ]

08-25-2003, 10:17 AM
I am in almost precisely the same situation. Red Hat 8, Hauppauge WinTV card shows up fine under mlquery, but vidtogfx doesn't work.

I emailed their support and got some feedback--turns out the original video code was written for SGI boards and the video for linux cards may not support all the calls in the code.

He suggested commenting out the whole block of code that starts 'if timing not specified'. I tried this, but it just failed slightly later in the code.

You can check what parameters your card/jack supports with mlquery -d "device" -j "jackname" -v "all". It will be quite a list. I'm currently going through the code, trying to figure out how to cut it down to requesting something my card can output.

Drop me a line if you figure out something--
eliot (AT) cinital.com. I'm thinking of trying one of the videoforlinux2 boards like a MiroDC30 as I have one.