View Full Version : Compile OpenMax with GCC

Arnaud Frigout
04-08-2010, 01:28 AM
Hello all,

I want to use le library OpenMax to do a FFT using Q1.31 (type int32, function in OpenMax : omxSP_FFTFwd_CToC_SC32_Sfs) in Kernel Linux 2.6.31 on an IMX51. When I compile the library OpenMax with GCC, the compilation doesn't work. I have try to use the library compiled by Freescale support with ARM's compiler but this doesn't work.
So can you help me to compile OpenMax with GCC?

I'm using the CodeSourcery's toolchain (arm-2009q3-67-arm-none-linux-gnueabi : http://www.codesourcery.com/sgpp/lite/a ... elease1039 (http://www.codesourcery.com/sgpp/lite/arm/portal/release1039)) and I can't use the ARM's compiler for my project.
Please can you help me?

05-31-2010, 05:23 PM
Try compiling on RVDS and then link using code sourcery.In RVDS,use softvfp,as code sourcery lite edition does not sup[port hard floating point option.Openmax,directly on gcc won't compile because it does not follow gas format,it follows armcc(RVDS)format

11-21-2011, 05:13 PM

I tried to use ARM's OpenMAX DL implementation in a GCC project.

The OpenMax library is compile by build_sp.pl, using armcc from DS-5 with the following change

$CC_OPTS = '--no_unaligned_access --dwarf2 --debug --asm --interleave --gnu --signed_bitfields
--no_hide_all --library_interface=aeabi_glibc --cpu=Cortex-A8 --fpu=SoftVFP+VFPv3 -Otime --vectorize
--enum_is_int --wchar32 --remarks --asm -O3 -c';

Then resultant static lib is linked to a simple program using DS-5's GCC. I got a lot of this error

uses VFP register arguments, ds5-gcc-test does not

Any idea?