Results 1 to 2 of 2

Thread: [SOLVED] Xerces XSD and COLLADA 1.4

  1. #1

    [SOLVED] Xerces XSD and COLLADA 1.4

    Hi, guys!
    I have such a trouble: I've created all needed stuf with xerces XSD (*.hxx and *.cxx files) and wrote a very simple program, which should tell me whatewer it finds "library_geometry" in the *.dae file. I used "cxx-tree". My code compiled fine, but when I tried to run this program for cube.dae (basic sample), I got a lot of messages like "error: no declaration found for element 'COLLADA'". WTF? Have anybody got the same? Or I'm just a noob (no comments :P )? I think, *.dae file doesn't consists link to the *.xsd file. But how to add it? I've tried many ways but got no results...
    Can anybody help me???

  2. #2
    Senior Member
    Join Date
    Aug 2004

    Re: [SOLVED] Xerces XSD and COLLADA 1.4

    Sounds like you have enabled XML validation with Xerces so it is looking for the COLLADA schema document. There should be a Xerces API call to disable validation if you don't really want it.

    Otherwise, can you post your <COLLADA> element in your test .dae file?

    I found this link at the Xerces web site that might help you (

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Proudly hosted by Digital Ocean