Results 1 to 6 of 6

Thread: mesa-vulkan-drivers not working on Ubuntu 18.04 ? vulkan-smoketest fails

  1. #1
    Junior Member Newbie
    Join Date
    Oct 2018
    Posts
    10

    mesa-vulkan-drivers not working on Ubuntu 18.04 ? vulkan-smoketest fails

    I am on Ubuntu 18.04 with an Intel CPU (8700k Coffee Lake) and a GTX 650 graphics card.

    I have the nvidia propretary drivers 390.87 installed for the GTX 650, and `vulkan-smoketest` succeeds (see the flying teapots) when I run it using the GTX 650 with just the nvidia drivers installed.

    When I install `mesa-vulkan-drivers` for the 8700k Intel HD Graphics and run `vulkaninfo` I see both the GPUs show up as expected:
    Code :
    		GPU id       : 0 (Intel(R) HD Graphics (Coffeelake 3x8 GT2))
    		GPU id       : 1 (GeForce GTX 650)
    however when I run `vulkan-smoketest` it tries to use the Intel GPU (as the first listed physical device I guess?). A window appears but it is black and I am unable to close it without killing the process.

    If I run `vulkan-smoketest --v` I get:

    Code :
        $ vulkan-smoketest --v
        Validation: Object: VK_NULL_HANDLE (Type = 0) | Shader requires vertexPipelineStoresAndAtomics but is not enabled on the device
        Validation: Object: 0x21 (Type = 9) | vkBindBufferMemory(): Binding memory to buffer 0x21 but vkGetBufferMemoryRequirements() has not been called on that buffer.

    Any ideas? Is there a better forum to report this? It's unclear who would care this isn't working? The mesa folks? Intel?

  2. #2
    Senior Member Regular Contributor
    Join Date
    Mar 2016
    Posts
    351
    I think vulkan-smoketest is no longer part of the SDK. I suggest you first try cube to verify your Vulkan install.

    And I suggest to update your SDK, if you are a programmer. That means getting it from https://vulkan.lunarg.com/sdk/home, instead of the notoriously obsolete Linuxey packages.

    Similarly you can try updated drivers from
    https://launchpad.net/~paulo-miguel-...e/ubuntu/pkppa
    or from
    https://launchpad.net/~oibaf/+archiv...aphics-drivers.
    Last edited by krOoze; 10-04-2018 at 07:37 AM.

  3. #3
    Senior Member Regular Contributor
    Join Date
    Mar 2016
    Posts
    351
    PS the demo comes from https://github.com/KhronosGroup/Vulkan-Tools. It was deleted in April.

  4. #4
    Junior Member Newbie
    Join Date
    Oct 2018
    Posts
    10

    Cube doesn't work either

    I have built cube by running build_examples.sh from the SDK version 1.1.82.1. Using cube I observe the same behaviour as vulkan-smoketest.

    That is, cube runs fine with just the nvidia drivers installed. After installing `mesa-vulkan-drivers` cube shows a black window and cannot be closed without killing the program.

    I will take a look at the updated driver links.

    Quote Originally Posted by krOoze View Post
    I think vulkan-smoketest is no longer part of the SDK. I suggest you first try cube to verify your Vulkan install.

    And I suggest to update your SDK, if you are a programmer. That means getting it from https://vulkan.lunarg.com/sdk/home, instead of the notoriously obsolete Linuxey packages.

    Similarly you can try updated drivers from
    https://launchpad.net/~paulo-miguel-...e/ubuntu/pkppa
    or from
    https://launchpad.net/~oibaf/+archiv...aphics-drivers.

  5. #5
    Junior Member Newbie
    Join Date
    Oct 2018
    Posts
    10
    FYI I have tried updating the drivers using the links provided, and the problem persists unchanged.

    Quote Originally Posted by Andrew Tomazos View Post
    I have built cube by running build_examples.sh from the SDK version 1.1.82.1. Using cube I observe the same behaviour as vulkan-smoketest.

    That is, cube runs fine with just the nvidia drivers installed. After installing `mesa-vulkan-drivers` cube shows a black window and cannot be closed without killing the program.

    I will take a look at the updated driver links.

  6. #6
    Senior Member Regular Contributor
    Join Date
    Mar 2016
    Posts
    351
    Hmm,
    try it in isolation. Connect the monitor to the Intel, and disable the dedicated card in BIOS (or remove it from the PC if you are not lazy).

Similar Threads

  1. Replies: 1
    Last Post: 12-06-2018, 01:17 AM
  2. I can not get vulkan to work with mesa drivers
    By legolasdk in forum Vulkan
    Replies: 8
    Last Post: 01-25-2018, 11:14 AM
  3. Replies: 1
    Last Post: 01-25-2018, 06:25 AM
  4. Replies: 4
    Last Post: 12-12-2016, 05:26 AM
  5. Replies: 0
    Last Post: 05-23-2016, 02:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean