Results 1 to 2 of 2

Thread: GLimp_EndFrame() - SwapBuffers Failed !

  1. #1
    Junior Member Newbie
    Join Date
    Jun 2000
    Location
    Florianopolis/SC/Brasil
    Posts
    3

    GLimp_EndFrame() - SwapBuffers Failed !

    There is a possible problem with Quake II running on Windows 2000. When I try to use it with the default OpenGL option it gives the message "GLimp_EndFrame() - SwapBuffers Failed !".

    My system is a AMD K6II-500 in a Soyo MB with 128 MB of RAM. Video Board is a Diamond Viper v770 Ultra with a RIVA TNT2 Ultra processor.

    I have already tried to copy the OPENGL32.DLL renamed to REF_GL.DLL to the Quake folder, but I think that it's not the way.

    Anyone have some light (or the same problem).

    Thanks in advance.
    -----------
    Dagostin

  2. #2
    Guest

    Re: GLimp_EndFrame() - SwapBuffers Failed !

    I have the same problem. I got around it using the NVIDIA Display Driver for Windows NT 4.0 version 3.68, 12/30/1999. They seem to work very stable in windows 2k. They only way I could get them to work though was to wipe my harddrive and reinstall windows 2k from scratch and then replace the default windows 2k drivers with the nt 4.0. I did this once before in the past with out wiping the drive clean, but it was alot of deleting of the registry and some nv*.* files in the c:\winnt directory. If you need a copy of the 3.68 drivers, let me know and I will email them to you. my email is sjoe@home.com. Hope this helps you. I was ****ed that the new nvidia win2k 5.22 drivers do not seem to
    work correctly with quake2 and I am still not sure why!!! I sent nvidia a email to tech support and have heard nothing. We will see.

Similar Threads

  1. SwapBuffers performance
    By little_endian in forum OpenGL: Windows
    Replies: 9
    Last Post: 01-09-2007, 06:23 PM
  2. Swapbuffers priority
    By macarter in forum OpenGL: Advanced Coding
    Replies: 34
    Last Post: 04-23-2006, 09:12 AM
  3. Failed Swapbuffers and wglMakeCurrent in WinNT/OpenGL app
    By Luis in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 09-27-2001, 09:46 PM
  4. SwapBuffers
    By spidey in forum OpenGL: Basic Coding
    Replies: 5
    Last Post: 08-09-2001, 11:51 AM
  5. Using HDC after SwapBuffers(HDC hdc)
    By Coconut in forum OpenGL: Advanced Coding
    Replies: 2
    Last Post: 03-16-2001, 05:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean