Results 1 to 3 of 3

Thread: render to ALPHA texture sux with NVIDIA cards ?!

  1. #1
    Junior Member Newbie
    Join Date
    Mar 2005
    Posts
    2

    render to ALPHA texture sux with NVIDIA cards ?!

    dear all !

    i have a rather simple algorithm that renders an object to a texture. now i want to use several of these textures to fake some kind of "motionblur".
    i do the following:

    glClearColor(1.0f, 1.0f, 1.0f, 0.f); //ALPHA 0 !!
    glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);
    pMyObject->Render();
    glBindTexture(GL_TEXTURE_2D,myTextureGLINT);
    glCopyTexImage2D(GL_TEXTURE_2D, 0, GL_RGBA, 0, 0, g_Viewport, g_Viewport, 0);

    later on i render this texture via:

    glColor4f(1.f,1.f,1.f,alpha); //alphafade
    glBindTexture(GL_TEXTURE_2D, myTextureGLINT);

    so far so good - works totally nice on ATI cards - but not at all on NVIDIA (latest driver - no question, different models) - any ideas on this ???
    do i eventually have to use some "strange" NV_ extension to make this work ??
    please help !!!

    thnx & many greetings
    k.

  2. #2
    Senior Member Regular Contributor
    Join Date
    Aug 2004
    Location
    Angers, France
    Posts
    245

    Re: render to ALPHA texture sux with NVIDIA cards ?!

    Is it because my shaders didn't work with ATI cards that I say: "OMFG, ATI suxx !" ? No, I say: "Erks, another crappy bug, ok no panic, i'll debug this"

    I'm quite sure there is some craps or mistakes in your code, not especially inside your transformation function..
    The .Product will make you .Believe

  3. #3
    Senior Member Frequent Contributor
    Join Date
    May 2001
    Location
    France
    Posts
    765

    Re: render to ALPHA texture sux with NVIDIA cards ?!

    Are you sure your buffer uses an alpha channel ?
    please call glGetInteger with GL_ALPHA_BITS.

Similar Threads

  1. FTGL fails to render on NVIDIA cards
    By Lee_Wilson in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 03-02-2009, 06:40 AM
  2. Render to Texture and keeping alpha
    By uzu_manga in forum OpenGL: Advanced Coding
    Replies: 5
    Last Post: 08-26-2005, 02:59 PM
  3. render to alpha texture sux with NVIDIA cards !?
    By hgore in forum OpenGL: Advanced Coding
    Replies: 1
    Last Post: 03-11-2005, 05:02 AM
  4. Render To Texture Problem : No Alpha
    By [hjd_uk] in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 11-02-2003, 02:25 AM
  5. About Render to depth texture in ATI Cards?
    By zhq424 in forum OpenGL: Advanced Coding
    Replies: 7
    Last Post: 09-14-2003, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean