Results 1 to 2 of 2

Thread: glDrawElements() problem

  1. #1
    Guest

    glDrawElements() problem

    It seems that the vertex refered to by the first indices of the indices arrat is refered to to often. this gives a distorted image where there are polygons all beginning at this first vertex all through the model.
    If you can help me please, I also have a document with my code on the output off the screen which i could mail to you.
    thanks for your time and i hope to have a solution soon.

  2. #2
    Senior Member Regular Contributor
    Join Date
    Jul 2000
    Location
    Nice, France
    Posts
    201

    Re: glDrawElements() problem

    Are you sure you are not passing GL_TRIANGLE_FAN to glDrawElements?
    If so, GL_TRIANGLES would probably be more appropriate.

Similar Threads

  1. glDrawElements Problem
    By Henry Rust in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 08-14-2010, 12:03 PM
  2. glDrawElements problem
    By wh1sp3rik in forum OpenGL: Advanced Coding
    Replies: 4
    Last Post: 11-12-2009, 03:39 AM
  3. glDrawElements problem
    By rozz666 in forum OpenGL: Advanced Coding
    Replies: 1
    Last Post: 07-02-2004, 01:41 PM
  4. problem with glDrawElements
    By jide in forum OpenGL: Linux
    Replies: 2
    Last Post: 11-23-2001, 02:17 AM
  5. problem w/ glDrawElements
    By Spiral Man in forum OpenGL: Basic Coding
    Replies: 9
    Last Post: 09-21-2001, 02:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean