Results 1 to 8 of 8

Thread: openGL on WINNT

  1. #1
    Junior Member Newbie
    Join Date
    Jun 2000
    Location
    surabaya, east java, indonesia
    Posts
    24

    openGL on WINNT

    i got a problem using openGL on windows NT (my operating system is Win NT ver 4.0 with service pack ver 5.0). Whenever i want to execute the application using openGL.dll, the crash always happened, so i can't execute the exe ......
    Why my appication ask for the openGL.dll ?
    instead of openGL32.dll
    If there some setup or option that have to been set before i use openGL on win nt ?


    [This message has been edited by andyazis (edited 06-27-2000).]

  2. #2
    Junior Member Newbie
    Join Date
    Jul 2000
    Location
    Absurdistan
    Posts
    15

    Re: openGL on WINNT

    isn't the opengl.dll SGI's file and the opengl32.dll microsofts? you've probably have those mixed.. -they don't

    (and the for the sgi-version, I think it's not even supported anymore???)

    jonn

  3. #3
    Junior Member Newbie
    Join Date
    Jun 2000
    Location
    surabaya, east java, indonesia
    Posts
    24

    Re: openGL on WINNT

    thank's jonn,
    but why, when my application run, is always require opengl.dll ?
    i already try to move the opengl.dll and use opengl32.dll but now i can't show my window application (only MS-DOS shell window that showed)

  4. #4
    Member Newbie
    Join Date
    May 2000
    Location
    LONDON
    Posts
    46

    Re: openGL on WINNT

    When you created your application, did you link against the correct opengl library ?? I am not sure if that could affect you.

    Dan.
    Being crazy is not a requirement but it helps.

  5. #5
    Junior Member Newbie
    Join Date
    Feb 2000
    Location
    Reading,England
    Posts
    17

    Re: openGL on WINNT

    I think that you may beable to just make a copy of the opengl32.dll and rename it to opengl.dll

    so you have two opengl.dll files in your sytem32 directory:

    opengl.dll and
    opengl32.dll
    kev.

  6. #6
    Junior Member Newbie
    Join Date
    Jun 2000
    Location
    surabaya, east java, indonesia
    Posts
    24

    Re: openGL on WINNT

    thank's
    but here are some trick that i aleady try:
    1. i aleady put on opengl.dll on window\system
    2. and put on the opengl32.dll on window\system32
    3. the link that i made were consist of : glaux.lib, glu32.ib, glut.lib glut32.lib and opengl32.lib

    but still i got the same
    isn't my os (winnt) in trouble or what ?

  7. #7
    Senior Member Regular Contributor
    Join Date
    May 2000
    Location
    Batavia, NY, 14020
    Posts
    234

    Re: openGL on WINNT

    First off, you're linking against OpenGL32.dll, Microsoft's implementation. If what you did is copy the SGI OpenGL.dll file to the winnt\system32 dir, its not going to work.

    First, I would suggest the following...

    extract the microsoft opengl32.dll file from the cd or the service pack (if the service pack updates it). Recompile, if it works, then try to run it. If it runs, it means you corrupted your opengl32.dll file when you tried to "install" the other opengl.

    Secondly, to use the microsoft implementations of opengl, make sure that you're including gl/gl.h, gl/glu.h, and gl/glaux.h (if you need it). if you're trying to use the SGI implementation of opengl, then INSTALL IT ACCORDING TO THE INSTALL INSTRUCTIONS and follow the coding guidelines that come with it to specify the includes and the libs.

    As of right now, your app sounds like its screwed up because you're trying to use the microsoft libraries with the sgi dll.

    Siwko
    - I am not opensource! -

  8. #8
    Junior Member Newbie
    Join Date
    Jun 2000
    Location
    surabaya, east java, indonesia
    Posts
    24

    Re: openGL on WINNT

    thank's a lot guys

Similar Threads

  1. OpenGL WinNT problem
    By gstrickler in forum OpenGL: Advanced Coding
    Replies: 10
    Last Post: 04-30-2002, 05:50 AM
  2. Failed Swapbuffers and wglMakeCurrent in WinNT/OpenGL app
    By Luis in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 09-27-2001, 09:46 PM
  3. OT: GLmark on winNT
    By V-man in forum OpenGL: Basic Coding
    Replies: 9
    Last Post: 08-09-2001, 06:48 PM
  4. WinNT 4 , Elsa Gloria II /III & FULL OpenGL 1.2
    By iss in forum OpenGL: User Software
    Replies: 0
    Last Post: 10-15-2000, 05:48 AM
  5. Upgrade WinNT OpenGL 1.0 to 1.1
    By in forum OpenGL: User Software
    Replies: 0
    Last Post: 09-29-2000, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean