Results 1 to 7 of 7

Thread: Texturing gives me horribly slow framerates. Why?

  1. #1
    Junior Member Newbie
    Join Date
    Jun 2001
    Location
    Grays, Essex, England
    Posts
    26

    Texturing gives me horribly slow framerates. Why?

    Hi,

    I have an AMD Thunderbird 900MHz, ATI Rage Fury 128 AGP (32Mb), and 96Mb PC100 RAM. When I texture some triangles in OpenGL (using Nehe's code), my framerate drops horrifically. I have a theory that maybe it's not being sent to video memory.. any ideas on this? Why is it so slow?
    Rottbott

  2. #2
    Senior Member Frequent Contributor
    Join Date
    Sep 2000
    Location
    SWEDEN
    Posts
    601

    Re: Texturing gives me horribly slow framerates. Why?

    The pixelformat might not be accelerated, if so you're getting software rendering. Try switching to 16bit colour.

  3. #3
    Senior Member OpenGL Guru zed's Avatar
    Join Date
    Nov 2010
    Posts
    2,466

    Re: Texturing gives me horribly slow framerates. Why?

    it does sound like u have software unacceleration try glGetString( GL_VENDOR )

  4. #4
    Junior Member Newbie
    Join Date
    Jun 2001
    Location
    Grays, Essex, England
    Posts
    26

    Re: Texturing gives me horribly slow framerates. Why?

    I'm using 16 bit colour. My card does run 32 bit colour nice and quick though usually..

    I've never used glGetString before, how can I display it?
    Rottbott

  5. #5
    Senior Member OpenGL Guru zed's Avatar
    Join Date
    Nov 2010
    Posts
    2,466

    Re: Texturing gives me horribly slow framerates. Why?

    char *str = glGetString( GL_VENDOR );
    printf("%s\n", str );

  6. #6
    Guest

    Re: Texturing gives me horribly slow framerates. Why?

    I think you gotta use char *str = (char *)glGetString( GL_VENDOR ) at least I have to for c++. But performance does tank when you use textures, especially if you use large textures. If you have blending etc on it'll tank it even more.

  7. #7
    Senior Member OpenGL Guru
    Join Date
    Mar 2001
    Posts
    3,574

    Re: Texturing gives me horribly slow framerates. Why?

    Just to make sure that you aren't making one of the common early mistakes, you aren't by chance calling glTexImage2D every frame, are you?

Similar Threads

  1. Replies: 1
    Last Post: 03-19-2013, 04:34 PM
  2. slow 2D-texturing in GLUT
    By Extinction in forum OpenGL: General
    Replies: 10
    Last Post: 06-17-2008, 02:20 PM
  3. VBO/VP/AttribArrays Horribly slow on GFFx 5200Ultra
    By tweakoz in forum OpenGL: Advanced Coding
    Replies: 31
    Last Post: 11-13-2003, 11:29 AM
  4. wglUseFontOutlines - horribly slow
    By angryGLfan in forum OpenGL: Basic Coding
    Replies: 10
    Last Post: 05-13-2002, 08:05 AM
  5. Strange framerates....
    By mk in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 12-29-2000, 03:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean