Results 1 to 5 of 5

Thread: Problems within VBO and PBuffer

  1. #1
    Senior Member Regular Contributor LangFox's Avatar
    Join Date
    Oct 2001
    Location
    Shen Zhen, Guangdong, China
    Posts
    102

    Problems within VBO and PBuffer

    Hello everyone,

    When I draw triangles with vbo while the pbuffer is actived, the exe crashes. Then I change to vertex array, it goes ok. Does pbuffer not work with vbo?

    ps, my graphic card is GeForce 6800 LE.
    Best Regards,
    LangFox


    http://hi.baidu.com/lang_fox

  2. #2
    Senior Member OpenGL Pro
    Join Date
    Jul 2001
    Location
    France
    Posts
    1,662

    Re: Problems within VBO and PBuffer

    Use FBO instead of pbuffers. pbuffers are deprecated on such cards.
    Anyway for answering your question, nothing says that VBO along with pbuffer does not work. It might be a driver bug.

  3. #3
    Senior Member Regular Contributor LangFox's Avatar
    Join Date
    Oct 2001
    Location
    Shen Zhen, Guangdong, China
    Posts
    102

    Re: Problems within VBO and PBuffer

    Thanks.

    I can not use FBO because the client's video card doesn't support it...
    Best Regards,
    LangFox


    http://hi.baidu.com/lang_fox

  4. #4
    Senior Member OpenGL Pro
    Join Date
    Jul 2001
    Location
    France
    Posts
    1,662

    Re: Problems within VBO and PBuffer

    Did you use wglShareList ? If not, use it with GL_TRUE so that textures, VBO... can be shared with pbuffers. If you did, I'm really of no-help.

  5. #5
    Senior Member Regular Contributor LangFox's Avatar
    Join Date
    Oct 2001
    Location
    Shen Zhen, Guangdong, China
    Posts
    102

    Re: Problems within VBO and PBuffer

    YES, that's the KEY!!

    Thanks! It's solved.
    Best Regards,
    LangFox


    http://hi.baidu.com/lang_fox

Similar Threads

  1. Problems using Pbuffer for water rendering.
    By iceworld in forum OpenGL: Basic Coding
    Replies: 5
    Last Post: 09-08-2009, 10:20 AM
  2. pbuffer copy problems
    By cmg in forum OpenGL: Advanced Coding
    Replies: 1
    Last Post: 05-27-2005, 05:20 AM
  3. Pbuffer PROBLEMS
    By imported_Ffelagund in forum OpenGL: Advanced Coding
    Replies: 12
    Last Post: 12-11-2003, 04:25 AM
  4. Multitexturing problems in pbuffer?
    By alantangcs in forum OpenGL: Advanced Coding
    Replies: 5
    Last Post: 12-02-2003, 02:51 AM
  5. PBuffer performance problems
    By LaBasX2 in forum OpenGL: Advanced Coding
    Replies: 14
    Last Post: 09-01-2002, 09:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean