Results 1 to 3 of 3

Thread: Textures problem

  1. #1
    Guest

    Textures problem

    I draw a box with 6 textures and inside of it (the viewing position is in the box)
    a set of triangles .
    For some reason I can`t get true colors for the triangles ( instead of the ones I define , I get green colors).
    I use 2 modes - non textured and a textured one , and it occures only in the textured mode .

  2. #2
    Member Contributor
    Join Date
    Feb 2000
    Location
    Breda, Netherlands
    Posts
    57

    Re: Textures problem

    When drawing a polygon with GL_TEXTURE_2D (or something like it), and not setting any texture points, your polygon will get the color of the point (0,0) of the texture (i guess). So when drawing a polygon without a texture you must set glDisable(GL_TEXTURE_2D);

    well, this is what I found to be true. Don't know if it can be done differently.

    John

  3. #3
    Guest

    Re: Textures problem

    Thanks !!
    It works.

Similar Threads

  1. Textures problem
    By Eddywards in forum OpenGL: macOS
    Replies: 5
    Last Post: 10-26-2006, 02:27 AM
  2. Problem with HDR textures.
    By Baggio in forum OpenGL: Advanced Coding
    Replies: 6
    Last Post: 11-06-2005, 12:04 PM
  3. problem with textures
    By ninjarider in forum OpenGL: Basic Coding
    Replies: 12
    Last Post: 08-12-2005, 10:22 AM
  4. textures problem
    By in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 10-10-2004, 03:09 AM
  5. Problem With Some BMP Textures
    By ndj55 in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 10-30-2001, 12:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean