Results 1 to 5 of 5

Thread: Texture Artifacts

  1. #1
    Junior Member Newbie
    Join Date
    Sep 2006
    Location
    Edmonton, AB
    Posts
    4

    Texture Artifacts

    The version of OpenGL I've got is 1.5.2
    OS is Windows XP Professional, Service Pack 2

    I was getting the following 'artifacts' when I was using GL_REPEAT.


    When I changed to GL_CLAMP_TO_EDGE or GL_CLAMP, the artifact went away... unless the quad is moving.


    While the quad is moving, the line flickers - seems like a rounding issue?

    How do I get rid of this line?

    Mark

  2. #2
    Senior Member OpenGL Pro k_szczech's Avatar
    Join Date
    Feb 2006
    Location
    Poland
    Posts
    1,107

    Re: Texture Artifacts

    I've never had such problems on any hardware. Make sure your texture data is correct.
    What's the width of your texture? Perhaps it's an allignment problem.

  3. #3
    Junior Member Newbie
    Join Date
    Sep 2006
    Location
    Edmonton, AB
    Posts
    4

    Re: Texture Artifacts

    Could be an alignment issue.

    What I'm doing is making a texture (power of 2 dimension).
    Then I'm allocating a block of data to draw into.

    I'm using Gdiplus to draw into the data before copying the data to the texture with glTexSubImage2D.

    What I want to try is using a texture of arbitrary size. Then I'll use the actual dimensions of the texture instead of floats... however I don't know where to find documentation on this feature -- other than buying the book from Amazon...

  4. #4
    Junior Member Newbie
    Join Date
    Sep 2006
    Location
    Edmonton, AB
    Posts
    4

    Re: Texture Artifacts

    http://www.opengl.org/registry/specs..._rectangle.txt
    This should be the ticket to using NPOTS, eh

  5. #5
    Junior Member Newbie
    Join Date
    Sep 2006
    Location
    Edmonton, AB
    Posts
    4

    Re: Texture Artifacts

    That did the trick! using GL_TEXTURE_RECTANGLE_ARB removed the artifact!

Similar Threads

  1. Texture atlas artifacts
    By dmitry in forum OpenGL ES
    Replies: 0
    Last Post: 08-18-2016, 02:35 AM
  2. 3D texture rendering artifacts
    By vincent911001 in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 04-07-2015, 07:54 PM
  3. Texture artifacts and std::map crash
    By Zylzyl in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 01-02-2014, 08:05 PM
  4. Transparent Texture - Artifacts
    By Andrew Jameson in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 07-10-2005, 04:09 AM
  5. help plea: unwanted texture artifacts
    By baggins in forum OpenGL: Advanced Coding
    Replies: 2
    Last Post: 02-24-2003, 04:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean