Results 1 to 3 of 3

Thread: textures mapping is wrong...

  1. #1
    Junior Member Newbie
    Join Date
    Oct 2004
    Posts
    14

    textures mapping is wrong...

    hi everyone

    I did textures mapping Image.
    but, The color of image was wrong.
    what's the matter?
    I need your help your advice.
    thank you.

  2. #2
    Senior Member Regular Contributor
    Join Date
    Jan 2004
    Posts
    314

    Re: textures mapping is wrong...

    Are you using your own image loading code?
    Are you passing the correct encoding when you upload the texture to the hardware?

    E.g. if you load a BMP file as RGB and then upload it you may into a little problem: BMP stores the bytes in the order BGR. In other words: red and blue are swapped.

  3. #3
    Member Newbie
    Join Date
    Dec 2004
    Location
    Mars
    Posts
    35

    Re: textures mapping is wrong...

    can you please post your code?
    there are too many cases in which this problem occurs.

Similar Threads

  1. My UV-mapping gets wrong colors?
    By ninjas in forum OpenGL: Basic Coding
    Replies: 4
    Last Post: 06-04-2018, 02:41 AM
  2. Omnidirectional shadow mapping and wrong space?
    By TheKaiser in forum OpenGL: Basic Coding
    Replies: 8
    Last Post: 06-13-2014, 01:35 AM
  3. Wrong UV mapping
    By nielzzz in forum COLLADA
    Replies: 1
    Last Post: 12-12-2008, 03:26 PM
  4. What's wrong with my texture mapping?
    By in forum OpenGL: Basic Coding
    Replies: 6
    Last Post: 07-28-2000, 12:10 AM
  5. What's wrong with my texture mapping?
    By in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 07-27-2000, 01:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean