Results 1 to 6 of 6

Thread: Windows XP Init Failes

  1. #1
    Junior Member Newbie
    Join Date
    Oct 2000
    Posts
    18

    Windows XP Init Failes

    Ive been coding in GL for a couple of years now.

    All my programs works fine in Windows 95,98 and 2000.
    But when Im trying them on XP the program failes with the following message:
    Failed to init error adress 0xc0000005.
    Doing some research I thinkits a accsess denied but WHY?

    Need help FAST.
    /Micke

  2. #2
    Member Contributor
    Join Date
    Dec 2000
    Location
    Connecticut/New Jersey/Nevada
    Posts
    51

    Re: Windows XP Init Failes

    Are you sure you have working OpenGL drivers? Do other programs work with OpenGL on that system?
    ~CGameProgrammer( );

  3. #3
    Guest

    Re: Windows XP Init Failes

    Make sure you download and install the drivers from NVidia.com.

    Microsoft (suprisingly enough) does not actually want you to use OpenGL, it wants you to use Direct3D - so it leaves support for OpenGL out, you have to install it with newer drivers.

  4. #4
    Senior Member OpenGL Pro
    Join Date
    Oct 2000
    Location
    Fargo, ND
    Posts
    1,753

    Re: Windows XP Init Failes

    Have you tried stepping through your app to find exactly where it's crashing? It's possible that the crash isn't OpenGL related at all. It's possible the other versions of windows were more forgiving of you improperly accessing memory somewhere.
    Deiussum
    Software Engineer and OpenGL enthusiast

  5. #5
    Member Contributor
    Join Date
    Dec 2000
    Location
    Connecticut/New Jersey/Nevada
    Posts
    51

    Re: Windows XP Init Failes

    That's a good point, it might not be an OpenGL error. But I'd don't think WinXP is less forgiving than Win2000. Still, memory errors do have the habit of lurking unseen for a while.
    ~CGameProgrammer( );

  6. #6
    Junior Member Newbie
    Join Date
    Oct 2000
    Posts
    18

    Re: Windows XP Init Failes

    I have the latest drivers and other OpenGL programs works fine.
    My init routines is taken straight from the OpenGL superbible 2nd edition
    so they should be okay.

    Since im not using XP myself its hard to find the error.
    Well , I guess I must dump all my **** to my brothers computer and compile
    the whole thing using XP.

    I hoped that someone could have encountered the same problem or am I
    the only "lucky" *******

Similar Threads

  1. init from DLL
    By Dman832 in forum OpenGL: Windows
    Replies: 2
    Last Post: 05-20-2011, 12:18 PM
  2. Component Init
    By krish_kish in forum OpenMAX
    Replies: 6
    Last Post: 05-13-2008, 11:08 AM
  3. tell me init() structure
    By pankajch in forum OpenMAX
    Replies: 1
    Last Post: 05-13-2008, 10:03 AM
  4. OpenGL Windows Init more simple
    By KILE in forum OpenGL: Advanced Coding
    Replies: 7
    Last Post: 08-27-2002, 06:03 AM
  5. init problem
    By Vlasko in forum OpenGL: Basic Coding
    Replies: 5
    Last Post: 02-18-2002, 02:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean