Results 1 to 4 of 4

Thread: Annoying texture problem with a 3d spinning cube

  1. #1
    Guest

    Annoying texture problem with a 3d spinning cube

    I've done my fair share of texture mapping, and I'm running into something I've never experienced before.

    I'm selecting my texture, then passing 36 vertices (of a cube) into the pipeline.

    I'm slowly spinning it around the y-axis, and I've noticed that whenever the front side is in front of the back side, the texture of the back side shows through the front! (ie. it looks like the front side temporarily disappears and is replaced by the back side texture)..

    I've tried everything from disabling blending,the depth buffer, cull mode and it's STILL happening...AGGHH!

    Any ideas?? I'm at my wits end here with this stupid problem..

  2. #2
    Senior Member Frequent Contributor
    Join Date
    Jan 2003
    Location
    Virginia
    Posts
    586

    Re: Annoying texture problem with a 3d spinning cube

    enable depth test and if that doesn't work and you are back face culling, verify that all of your quads were generated with the same winding - clockwise or counter-clockwise.

  3. #3
    Senior Member Regular Contributor
    Join Date
    Sep 2002
    Location
    Nanjing,China
    Posts
    116

    Re: Annoying texture problem with a 3d spinning cube

    it's quite strange indeed.Post your code here and let us have look.Just curious ,what kind of cube has 36 vertex while Usually the cube would have 8 vertex

  4. #4
    Guest

    Re: Annoying texture problem with a 3d spinning cube

    Heh...wouldn't you know it? I enabled the depth buffer and turned off the DepthMask...

    *sigh*

    thanks for the help gang!

Similar Threads

  1. How do I make a spinning cube?
    By qwerty5683 in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 10-25-2017, 12:35 PM
  2. Cube Env Mapping Texture problem
    By raoulduke in forum OpenGL: Basic Coding
    Replies: 6
    Last Post: 10-06-2004, 04:54 AM
  3. OpenGL and CBuilder - annoying problem
    By raybones in forum OpenGL: Basic Coding
    Replies: 4
    Last Post: 12-30-2003, 02:44 AM
  4. Replies: 0
    Last Post: 08-30-2003, 03:54 AM
  5. Weird annoying problem that's ruining my day.
    By in forum OpenGL: User Software
    Replies: 0
    Last Post: 08-01-2002, 02:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean