Results 1 to 5 of 5

Thread: Missing triangles.. where are they ?

  1. #1
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    Årsunda,gästrikland,Sweden
    Posts
    113

    Missing triangles.. where are they ?

    Hi out there!

    I got a problem.. I have made a nice ASE file reader but when I render my objects there ar triangles missing.. different triangles depends on the camera angel.. this is strange becouse I log the ASE read process to se that it doesn´t miss anything and I can´t se that it do.. anyone got an idea ?

    Thanks for your answer

  2. #2
    Senior Member OpenGL Pro
    Join Date
    Jun 2000
    Location
    Shreveport, LA, USA
    Posts
    1,502

    Re: Missing triangles.. where are they ?

    Are all the triangles oriented in the same fashion, i.e. front face clockwise or counter-clockwise? Simple test would be to disable face culling. If the triangles appear then the vertices of some of them need to be reordered.

  3. #3
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    Årsunda,gästrikland,Sweden
    Posts
    113

    Re: Missing triangles.. where are they ?

    I have tried that already.. and the triangles is still gone

  4. #4
    Member Newbie
    Join Date
    Aug 2001
    Location
    Switzerland
    Posts
    47

    Re: Missing triangles.. where are they ?

    I got such a appearance at my pc at work: I let a demo(glexcess) running with a matrox millenium g200 graphic card and there were trianles missing, too. When I let the demo run on a GF2MX, it runs perfectly...

    Maybe it's your graphics card or driver?

  5. #5
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    Årsunda,gästrikland,Sweden
    Posts
    113

    Re: Missing triangles.. where are they ?

    I have a Asus 7100 GeForce 2 MX 32mb... but it could be the drivers

Similar Threads

  1. missing triangles
    By zauron in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 05-03-2002, 02:37 AM
  2. Xm is missing
    By FoxDie in forum OpenGL: General
    Replies: 2
    Last Post: 02-24-2002, 11:57 AM
  3. ASE File problem.. missing Triangles
    By McZ in forum OpenGL: Basic Coding
    Replies: 7
    Last Post: 10-01-2001, 11:56 AM
  4. What am I missing here?
    By Ace_Man in forum OpenGL: Advanced Coding
    Replies: 0
    Last Post: 04-06-2001, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean