Results 1 to 4 of 4

Thread: Prob with HW acceleration and drawing text

  1. #1
    Junior Member Newbie
    Join Date
    Nov 2002
    Location
    Bedford Mass USA
    Posts
    1

    Prob with HW acceleration and drawing text

    This is from a programmer on my team:

    I'm creating more then 60 OpenGL contexts that draw a vignette background and some static text. I'm creating one static context used as a common
    context for storing display lists and I'm sharing this display-list space, using wglShareLists, with the created OpenGL context. The problem I have is that it stops drawing the text after the 10th context.
    When I turned off the hardware acceleration in the display setting it starts to work fine and displays all the text .

    The Graphic controller on my PC is Intel 82845G/GL. If it's a bug in the Intel 845G driver (we have the latest as of today) who can we follow up with at Intel?

    I found out that if I create a separate display list context for each 16 contexts it works fine even with the hardware acceleration turned on. Is this a common workaround?

    Does anyone have any suggestions? Thanks!

  2. #2
    Senior Member Regular Contributor
    Join Date
    Apr 2001
    Location
    Fort Collins, Colorado
    Posts
    446

    Re: Prob with HW acceleration and drawing text

    You'll probably have more luck getting this question answered in the "Advanced Coding" forum.

    Good luck!

  3. #3
    Senior Member OpenGL Guru
    Join Date
    Jun 2000
    Location
    Gastonia, NC, USA
    Posts
    2,068

    Re: Prob with HW acceleration and drawing text

    How are you drawing the text?
    Bitmap or texture?


    Originally posted by steverothman:
    This is from a programmer on my team:

    I'm creating more then 60 OpenGL contexts that draw a vignette background and some static text. I'm creating one static context used as a common
    context for storing display lists and I'm sharing this display-list space, using wglShareLists, with the created OpenGL context. The problem I have is that it stops drawing the text after the 10th context.
    When I turned off the hardware acceleration in the display setting it starts to work fine and displays all the text .

    The Graphic controller on my PC is Intel 82845G/GL. If it's a bug in the Intel 845G driver (we have the latest as of today) who can we follow up with at Intel?

    I found out that if I create a separate display list context for each 16 contexts it works fine even with the hardware acceleration turned on. Is this a common workaround?

    Does anyone have any suggestions? Thanks!

  4. #4
    Member Contributor
    Join Date
    May 2017
    Posts
    54

    Re: Prob with HW acceleration and drawing text

    Originally posted by steverothman:
    If it's a bug in the Intel 845G driver (we have the latest as of today) who can we follow up with at Intel.
    Hi Steve-

    Send me some email. If it is a bug in the Intel driver, I might be able to help you out.

    Thanks,
    -- Ben

Similar Threads

  1. Text drawing in GL 4.3
    By sam_thedancer in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 06-19-2013, 07:09 PM
  2. Drawing Text
    By Atomic_Sheep in forum OpenGL: Basic Coding
    Replies: 4
    Last Post: 05-10-2012, 11:47 AM
  3. CPW & drawing text using TTF
    By oshapir in forum OpenGL: General
    Replies: 2
    Last Post: 09-01-2002, 04:53 AM
  4. Drawing text
    By nnaro in forum OpenGL: Advanced Coding
    Replies: 1
    Last Post: 05-11-2000, 10:12 PM
  5. Drawing text
    By nnaro in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 05-01-2000, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean