Results 1 to 3 of 3

Thread: GLW_Startopen GL

  1. #1
    Junior Member Newbie
    Join Date
    Aug 2004
    Location
    Guatemala
    Posts
    1

    GLW_Startopen GL

    Hi, i'm from Guatemala City, and i wish someone can helpme!!!
    I want to play Quake 3 Arena, but when i start, give me one problem and is:
    Q3 1.11 win-x86 Nov 24 1999
    ----- FS_Startup -----
    Current search path:
    C:\Program Files\Quake III Arena\baseq3\pak0.pk3 (3539 files)
    C:\Program Files\Quake III Arena/baseq3

    ----------------------
    execing default.cfg
    execing q3config.cfg
    couldn't exec autoexec.cfg
    ...detecting CPU, found x86 (P5/Pentium2, MMX)

    ------- Input Initialization -------
    Initializing DirectInput...
    Couldn't set DI coop level
    Falling back to Win32 mouse support...
    Joystick is not active.
    ------------------------------------
    ----- Client Initialization -----
    ----- Initializing Renderer ----
    -------------------------------
    ----- Client Initialization Complete -----
    --- Common Initialization Complete ---
    Winsock Initialized
    Opening IP socket: localhost:27960
    Hostname: pc9
    IP: 192.168.1.9
    Working directory: C:\Program Files\Quake III Arena
    ----- R_Init -----
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\WINDOWS\SYSTEM\opengl32.dll' ): succeeded
    ...setting mode 3: 640 480 FS
    ...using desktop display depth of 32
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 32, 24, 8 )
    ...23 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 32, 24, 0 )
    ...23 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...setting mode 3: 640 480 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...23 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...23 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    ...assuming '3dfxvgl' is a standalone driver
    ...initializing QGL
    ...WARNING: missing Glide installation, assuming no 3Dfx available
    ...shutting down QGL
    ----- CL_Shutdown -----
    RE_Shutdown( 1 )
    -----------------------
    GLW_StartOpenGL() - could not load OpenGL subsystem

    i installed the latest version of my video card drive, but still have it.
    my os is Windows 98.

    I hope someone can helpme!!1

    THANKS

    p.d.: sorry by my english.

  2. #2
    Super Moderator OpenGL Lord
    Join Date
    Dec 2003
    Location
    Grenoble - France
    Posts
    5,574

    Re: GLW_Startopen GL

    Did you noticed the name of the forum you posted in ? it is written "OpenGL CODING:beginners".

    So where is your code ?

    Go to the GL 'gaming forum', and put your video card details, drivers details (version etc), run a tool like GLinfo and post what GL renderer it displays.

  3. #3
    Super Moderator OpenGL Guru imported_dorbie's Avatar
    Join Date
    Jul 2000
    Location
    Bay Area, CA, USA
    Posts
    3,966

    Re: GLW_Startopen GL

    Looks like you have an old graphics card that cannot support the kind of framebuffer quake tries to initialize. I'd recommend installing new drivers but since you've tried that you probably need a graphics card upgrade. Maybe you could try reducing your resolution first and changing the desktop color depth (try 16 then 32 bit (true color)) see if that helps.

    Closing thread, it is off topic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean