Results 1 to 4 of 4

Thread: A small problem, please help me...

  1. #1
    Junior Member Newbie
    Join Date
    Oct 2001
    Location
    Hong Kong
    Posts
    3

    A small problem, please help me...

    I am really a beginner.
    I made a simple "Racing" program in opengl.
    I indeed wanted to use double buffer and copy all the part for double buffer from book, but it acted as single buffer, flickered all the time. I do not know where
    I was wrong. Please help me.
    I indeed write "glutInitDisplayMode(...| GL_DOUBLE)" and "glutSwapBuffers()" in the display callback function.
    If you could take the trouble to go to my homepage: "http://ihome.ust.hk/~cszy" to see the program, I will be very grateful.
    Thank you very much!

  2. #2
    Guest

    Re: A small problem, please help me...

    glutInit(&argc, argv);
    glutInitDisplayMode(GLUT_DEPTH | GLUT_DOUBLE | GLUT_RGBA);

    worked for me

  3. #3
    Junior Member Newbie
    Join Date
    Oct 2001
    Location
    Hong Kong
    Posts
    3

    Re: A small problem, please help me...

    Thank you very much!
    But it doesn't work in my system.
    Actually, I use
    glGetBooleanv(GL_DOUBLEBUFFER, &bdouble)
    and I Found that bdouble=0, which indicates
    that maybe I cannot use double buffer at all.
    But my supervisor asked me to make double
    buffered program on this machine, and she is
    very anxious to see.
    What can I do?
    Thank you again!

  4. #4
    Junior Member Newbie
    Join Date
    Oct 2001
    Location
    Hong Kong
    Posts
    3

    Re: A small problem, please help me...

    Thanks for all.
    Now I know the error:
    glutInitDisplayMode(GLUT_DEPTH | GLUT_DOUBLE | GLUT_RGBA);
    should be positioned before:
    glutInitWindowPosition(0, 0);
    glutInitWindowSize(640, 480);
    glutCreateWindow("Racing");

    ^_^

Similar Threads

  1. small problem
    By Sayantan in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 12-18-2010, 04:56 AM
  2. Small VBO problem with NVIDIA
    By Cab in forum OpenGL: Advanced Coding
    Replies: 1
    Last Post: 06-19-2005, 05:30 AM
  3. a small glui problem
    By dvm in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 05-12-2004, 07:49 AM
  4. small ati driver problem redhat 9
    By in forum OpenGL: Linux
    Replies: 1
    Last Post: 10-17-2003, 12:01 AM
  5. A small problem
    By Kronos259 in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 05-28-2003, 04:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean