Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: aahhh.. Im going crazy...

  1. #1
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    rsunda,gstrikland,Sweden
    Posts
    113

    aahhh.. Im going crazy...

    I hate this... not exactly but I dont like when my triangles disaper... it seems like the computer is to slow to draw it befor it changes and should redraw it.. but a GeForce 2 mx cant be to slow to draw a cube with 12 triangles ?? and still they are disapering in some strange way.. it is wierd.. hard to explain to.. I will zip it tomorrow so you can download it from my homepage...

    Ill get back with the address... is there anyone with an idea ?

  2. #2
    Senior Member Frequent Contributor
    Join Date
    Aug 2000
    Location
    Portsmouth, Hampshire, England
    Posts
    926

    Re: aahhh.. Im going crazy...

    Perhaps your selected pixel format is forcing software rendering?

    Nutty

  3. #3
    Senior Member OpenGL Pro
    Join Date
    Jun 2000
    Location
    Shreveport, LA, USA
    Posts
    1,502

    Re: aahhh.. Im going crazy...

    Perhaps your triangle vertices are not all oriented in the same manner.

  4. #4
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    rsunda,gstrikland,Sweden
    Posts
    113

    Re: aahhh.. Im going crazy...

    Nutty : if the reply from glGetString(renderer) is GeForce 2 mx bla.. bla bla.. isnt it using hardwere then ?

    DFrey : I am reading from an .ASE file so they should be right. and the triangles is there in some viewpoints but then when I rotate the object they disapear ?! wierd and the faces in behind is shown thrue the object

    BTW. I will put the VC++ source and stuff here : www.freebox.com/mcz/mczopengl.zip

  5. #5
    Senior Member Frequent Contributor
    Join Date
    Sep 2000
    Location
    SWEDEN
    Posts
    601

    Re: aahhh.. Im going crazy...

    The zip is corrupted, so I can't verify this from the source, but have you enabled depth testing?

  6. #6
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    rsunda,gstrikland,Sweden
    Posts
    113

    Re: aahhh.. Im going crazy...

    harsman : yeah I know the server is mean to me.. I have used about 3,5mb of 25mb web-space but when I want to upload I cant becouse it says it full it is like they are steeling my space.. it wont help if I remove other files I cant put it there anyway

    and Yes I have depth testing I have tried to remove it but it didnt work.

  7. #7
    Senior Member OpenGL Guru
    Join Date
    Feb 2000
    Location
    Sweden
    Posts
    2,978

    Re: aahhh.. Im going crazy...

    >>if the reply from glGetString(renderer) is GeForce 2 mx bla.. bla bla.. isnt it using hardwere then ?

    Maybe, maybe not. It means that your hardware driver is responsible for rendering (and not MS's generic implementation), but whether the driver tells the hardware to render, or if the driver is performing a software rendering, you don't know.

  8. #8
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    rsunda,gstrikland,Sweden
    Posts
    113

    Re: aahhh.. Im going crazy...

    Bob : but it runs at about 60-70fps if I calculate it right. when I try it on my other computer with a ATI Rage 3D card the reply from glGetString(renderer) is "GDI Generic" so I asume that is software.

  9. #9
    Member Newbie
    Join Date
    Mar 2001
    Location
    New Zealand
    Posts
    39

    Re: aahhh.. Im going crazy...

    You said that the back faces show through the object when they should be being culled. To me that points to polygon winding. I'm guesing that you have face culling enabled? Your polygons might have a Counter clockwise rotation and you might have clockwise set as the front face or vice versa! To fix it just use glFrontFace() or glCullFace(GL_BACK) to tell gl what to cull.

  10. #10
    Senior Member Regular Contributor
    Join Date
    Dec 2000
    Location
    rsunda,gstrikland,Sweden
    Posts
    113

    Re: aahhh.. Im going crazy...

    Hi thanks for the help but I found the problem... in my ResizeGLScene this row was the problem
    gluPerspective(90.0f,(GLfloat)width/(GLfloat)height,0.1f,200.0f);

    instead of 200.0f it was 1000.0f and instead of 0.1f there was 0.0f I change that and then everyting works perfect

Page 1 of 2 12 LastLast

Similar Threads

  1. NDC goes crazy
    By PadMad in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 05-26-2016, 03:23 PM
  2. Crazy Quaternion
    By chiser98 in forum OpenGL: General
    Replies: 1
    Last Post: 06-15-2011, 10:41 AM
  3. Crazy Polygons?
    By Makinis in forum OpenGL: Basic Coding
    Replies: 11
    Last Post: 06-26-2009, 02:51 AM
  4. crazy idea...
    By imr1984 in forum OpenGL: Advanced Coding
    Replies: 5
    Last Post: 05-18-2004, 11:21 PM
  5. I'm coming crazy...help me
    By KurtCob in forum OpenGL: Advanced Coding
    Replies: 14
    Last Post: 12-05-2000, 11:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean