Results 1 to 2 of 2

Thread: problems with glMatrixMode

  1. #1
    Guest

    problems with glMatrixMode

    My program normally runs in model matrix mode, but I have one object that I want to draw using projection matrix mode. However, for some reason, after the first time I call glMatrixMode(GL_PROJECTION); none of my other stuff draws, even if I try to set the matrix mode back to model view. Any ideas what the problem might be?

    If it makes any difference, I am also using depth testing for the rest of my program, but disabling it at the same time as I call glMatrixMode(GL_PROJECTION), and re-enabling it at the end of the function.

  2. #2
    Guest

    Re: problems with glMatrixMode

    Nevermind, I figured it out. I was just pushing my matrix into the wrong stack.

Similar Threads

  1. glMatrixMode and 2D display
    By mbkelly in forum OpenGL: Basic Coding
    Replies: 5
    Last Post: 02-04-2019, 03:01 PM
  2. Replies: 5
    Last Post: 05-02-2012, 02:55 AM
  3. glMatrixMode error
    By SilverNoise in forum OpenGL: Basic Coding
    Replies: 9
    Last Post: 04-29-2004, 01:44 PM
  4. glMatrixMode?
    By Questions Burner in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 10-01-2001, 09:07 AM
  5. more for glMatrixMode
    By V-man in forum OpenGL: General
    Replies: 8
    Last Post: 07-10-2001, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean