Results 1 to 4 of 4

Thread: Artifacts in gluCylinder ????

  1. #1
    Senior Member Regular Contributor
    Join Date
    Oct 2005
    Posts
    137

    Artifacts in gluCylinder ????

    I am drawing some cylinders using gluCylinder and it is showing strange black artifacts on the cylinder if I rotate the scene. Lighting is enabled. does anybody know what could be the problem.

  2. #2
    Senior Member OpenGL Guru Relic's Avatar
    Join Date
    Apr 2000
    Posts
    2,450

    Re: Artifacts in gluCylinder ????

    Just a stab in the dark:
    Try to enable normalization of normals if you scale the cylinders.

  3. #3
    Senior Member Regular Contributor
    Join Date
    Oct 2005
    Posts
    137

    Re: Artifacts in gluCylinder ????

    Tried that.. didnt work, in the end the problem turned out that i had set the znear factor to 0.01 in gluPerspective. changing it to 0.1 removed the artifact. Thanx anyway.

  4. #4
    Member Contributor
    Join Date
    Feb 2001
    Location
    Slovakia
    Posts
    53

    Re: Artifacts in gluCylinder ????

    Another stab in the dark:
    Maybe your far limit in the frustum is too big.

Similar Threads

  1. gluCylinder - joining
    By TEWarehouse in forum OpenGL: Basic Coding
    Replies: 4
    Last Post: 12-01-2012, 07:22 AM
  2. How to rotate a gluCylinder 3D
    By VanceRegnet in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 11-10-2005, 09:59 AM
  3. gluCylinder
    By ThinIce in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 02-05-2002, 08:35 PM
  4. gluCylinder
    By nrbrasiliense in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 10-26-2001, 12:57 PM
  5. about gluCylinder
    By joeyx in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 04-21-2001, 05:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean