Results 1 to 2 of 2

Thread: Problems with SGIS_G_M

  1. #1
    Senior Member Frequent Contributor
    Join Date
    Nov 2002
    Location
    Latvia
    Posts
    626

    Problems with SGIS_G_M

    Plz help, I tried to use SGIS_GENERATE_MIPMAP, but nothing works, I've seen programs based on it that works well on my hw, but can't implement that in my prog I defined GL_GEN..SGIS 1918 or smthn like that don't remember, anyway then I call glTexparameteri(GL_TEXTURE2D, GL_GENERATE_MIPMAP_SGIS, GL_TRUE), but nothing works. The problem could be because I don't connect any image file with SGIS ext, but I haven't found how to do it Official EXT doc dosn't help a lot. Where can I find normal documentation without hiden commands & by the way, how to use SGIS hints & why SGIS_SHARPEN(or smthn like that) is unidentified identifier after defining GL_GEN.._MIP..._SGIS ?

  2. #2
    Senior Member OpenGL Guru
    Join Date
    Feb 2000
    Location
    Sweden
    Posts
    2,978

    Re: Problems with SGIS_G_M

    Every state change through glTexParameter affects only the bound texture on the active texture unit. So make sure the correct texture is bound and the proper texture unit active.

    I quickly read through the spec, and there's one thing I'm not sure about. Quoting the spec.
    If GENERATE_MIPMAP_SGIS is enabled, the side effect occurs whenever
    any change is made to the interior or edge image values of the base
    level texture array.
    So if you enable mipmap generations after you uploaded the texture, you don't get any mipmaps, since you don't modify it after it has been enabled. Not sure if this is the correct way to interpret it though. So basically you must bind the texture, enable mipmap generation, and then upload the texture.

    By the way, the correct constant is 0x8191 in case you got it wrong.

    [This message has been edited by Bob (edited 11-22-2002).]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean