Results 1 to 7 of 7

Thread: FPS under W2K sucks

  1. #1
    Member Newbie
    Join Date
    Nov 2001
    Posts
    44

    FPS under W2K sucks

    Hi all,

    I'm getting terrible FPS for my OGL code under W2K, 30 times slower that on Linux. I'm reading the depth component of the frame buffer and that seems to kill performance on W2K. It's fine on Linux (~120FPS) but for the same code and model I get ~4FPS under W2K. I'm having this problem under cygwin and VC++. I have GF3 with 64 MB RAM. What's going on under W2K? I have the latest nVidia drivers installed and I turned off vsync. Do I need to link against special libraries as opposed to the ones that come with VC++ and cygwin?


    Thanks,
    GGL

  2. #2
    Senior Member Regular Contributor
    Join Date
    Jan 2002
    Posts
    292

    Re: FPS under W2K sucks

    Update your Geforce driver with the one nvidia has on their site... The one that comes with windows is not optimized.

  3. #3
    Member Newbie
    Join Date
    Nov 2001
    Posts
    44

    Re: FPS under W2K sucks

    Do you mean libraries? I have installed the latest nVidia drivers from their site just last week. Do I need to link against nVidia's libraries and DLL's?

  4. #4
    Senior Member Frequent Contributor
    Join Date
    Aug 2000
    Location
    Portsmouth, Hampshire, England
    Posts
    926

    Re: FPS under W2K sucks

    Just need to link with
    Opengl32.lib and perhaps glu32.lib

    Check your render string with glGetString(GL_RENDERER); or something. Make sure this is what it should be. If it's 30 times slower, sounds like you're falling back to software mode. Perhaps you're trying to get an unsupported pixel format?

  5. #5
    Senior Member Regular Contributor
    Join Date
    Jan 2002
    Posts
    292

    Re: FPS under W2K sucks

    No, I mean the driver for your card...
    You dont have to link against their dlls because that was already done when you installed you driver...

    Another question... What version of VC++ are you using? .NET? If you are, are you using vectors to store your data? If you are, that is a problem I had and I redid my code with a dynamic array...

  6. #6
    Member Newbie
    Join Date
    Nov 2001
    Posts
    44

    Re: FPS under W2K sucks

    Nutty:

    I am linking with opengl32.lib, glu32.lib and glut32.lib. What should I expect from the. I'll check on the string and see. Thanks.

    mancha:
    I installed their latest drivers and I'm linking agaings the libraries I mentioned above. I'm using VC++ 6.0 with the latest service pack. My data is in vertex arrays that are dynamically allocated. Could that be a problem (vertex arrays that is)?

    Thanks,
    GarlicGL

  7. #7
    Senior Member Regular Contributor
    Join Date
    Nov 2000
    Posts
    370

    Re: FPS under W2K sucks

    Yeah, it sure seems like your not h/w accelerated at all.

    Could be the way you requested the pixel format, or some other things. If you want portability, use glut, since then the code is pretty much cross-platform.

    Or, goto a site like Nehe's, and get a tutorial, then gut it, and stick in your rendering code in it, and see what happens.

Similar Threads

  1. Instancing sucks ?
    By BionicBytes in forum OpenGL: Advanced Coding
    Replies: 54
    Last Post: 05-12-2010, 04:47 PM
  2. my voodoo4 sucks on CS
    By in forum OpenGL: User Software
    Replies: 0
    Last Post: 10-12-2002, 09:36 AM
  3. nvidia sucks!
    By in forum OpenGL: Linux
    Replies: 0
    Last Post: 04-09-2001, 05:35 PM
  4. blending sucks !!help!!
    By Lord Iceman in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 02-16-2001, 04:31 PM
  5. OpenGL SUCKS
    By in forum OpenGL: User Software
    Replies: 0
    Last Post: 02-05-2001, 02:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean