Results 1 to 3 of 3

Thread: problems with 8-bit color on win95/8

  1. #1
    Junior Member Newbie
    Join Date
    Mar 2000
    Location
    Baltimore, MD
    Posts
    8

    problems with 8-bit color on win95/8

    I have been unable to get an 8-bit color OpenGL application to work under win95/98. Oddly, it works fine on WinNT. It seems that calls to glIndexi(indx) or
    glMateriali(GL_FRONT_AND_BACK, GL_COLOR_INDEXES, indx[]) are somehow getting
    mangled, so that the color index that's used to render the object is not the
    same as what's passed in this call. This happens no matter whether lighting and dithering are enabled or disabled, and I'm running in color index mode (not 8-bit rgba). For example, I give it material indexes of,
    say, (10,10,10) - i.e. a solid color using the first non-static color in the
    system palette I've carefully set up - but when the object is drawn,
    suddenly it's using some other random color index (one of the static colors
    with index < 10), which I can see on the screen since it's the wrong color,
    as well as through glReadPixels which return the incorrect index.
    Has anyone else had this problem or know how I can get win95/8's OpenGL to
    let me index the system palette reliably?
    Thanks in advance,

    - Paul

  2. #2
    Junior Member Newbie
    Join Date
    Mar 2000
    Location
    Southampton England
    Posts
    13

    Re: problems with 8-bit color on win95/8

    Hi.
    Im having exactly the same problem. I wrote a program in 24/32 bit colour, which now needs to be run on an 8 bit platform. All colours just appear black or white, I have tried using RGB and INDEXED colour.

    Tom.
    Tom [img]/forum/images/%%GRAEMLIN_URL%%/smile.gif[/img]

  3. #3
    Member Newbie
    Join Date
    Mar 2000
    Location
    New Jersey
    Posts
    30

    Re: problems with 8-bit color on win95/8

    I had a related problem ( see the selection posting on this board ). I've found the only reliable way is to switch the machine to True Color mode and use RGBA not RGB. I've tested this on 98 and NT and it seems to work.
    Hope this helps
    fs http://fshana.tripod.com
    Francis Shanahan
    Architect

Similar Threads

  1. Where do i install Open GL 1.1 for WIN95 at?
    By Xero Mata in forum OpenGL: User Software
    Replies: 10
    Last Post: 04-24-2004, 08:08 AM
  2. GLSetup Only Runs on Win95 & Win 98
    By in forum OpenGL: User Software
    Replies: 0
    Last Post: 03-14-2002, 04:20 PM
  3. Opengl32.dll, Glu32.dll and Win95/NT4
    By lobstah in forum OpenGL: Advanced Coding
    Replies: 2
    Last Post: 05-24-2001, 04:10 AM
  4. Can't get OpenGL to work on Win95/98/ME
    By in forum OpenGL: User Software
    Replies: 6
    Last Post: 11-12-2000, 02:54 PM
  5. Hardware acc in Win95+Voodoo2+VB
    By edotorpedo in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 09-23-2000, 09:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean