Page 1 of 5 12345 LastLast
Results 1 to 10 of 45

Thread: Testers wanted ...

  1. #1
    Senior Member OpenGL Guru Humus's Avatar
    Join Date
    Mar 2000
    Location
    Stockholm, Sweden
    Posts
    2,342

    Testers wanted ...

    Hi everybody!

    I have done a little OpenGL app i want to check which hardware that it'll run at. It should look something like this: Shot.jpg
    This was rendered at my g400 which OpenGL drivers suck (no stencil or attenuation support) ...
    So if anybody want to test it you can download it at my homepage (0.5MB)
    (If you get like 2fps, edit the included ini-file and disable stenciling)

    Please tell me if it work on your hardware and what hardware you got. Any help is appreciated.


    [This message has been edited by Humus (edited 04-09-2000).]

    [This message has been edited by Humus (edited 04-09-2000).]

    [This message has been edited by Humus (edited 04-09-2000).]

  2. #2
    Senior Member Regular Contributor
    Join Date
    Feb 2000
    Location
    milano, italy
    Posts
    282

    Re: Testers wanted ...

    hi humus.

    as i start the demo, it changes the resolution, shows the white screen and then crashes with the debug windows dialog box.
    it leaves the desktop to the new resolution.
    i've tried any combinations of ini params.

    i have a pII 350 w/64megs, a tnt w/16megs

    hope you fix it: good shots!
    is the fire procedural?

    Dolo/\/\ighty
    Dolo/\/\ightY

  3. #3
    Senior Member OpenGL Guru Humus's Avatar
    Join Date
    Mar 2000
    Location
    Stockholm, Sweden
    Posts
    2,342

    Re: Testers wanted ...

    Hmmm ... that's bad ...
    What error message did it give? And what OS are you running? From what i know it doesn't seam to run under win2k ...

    And Yes, the fire is procedural, and so is the flash above it.

  4. #4
    Senior Member Regular Contributor
    Join Date
    Feb 2000
    Location
    milano, italy
    Posts
    282

    Re: Testers wanted ...

    oh right, i forgot the OS... it's win32.
    windows '98 se.

    it crashes with no particular messages, just the windows dialog box with the three pushbuttons, debug, details... you got it?

    even if i didn't see it operating, i'd like to compare your fire with mine. can you give some code?

    Dolo/\/\ightY

    [This message has been edited by dmy (edited 04-09-2000).]
    Dolo/\/\ightY

  5. #5
    Senior Member OpenGL Guru Humus's Avatar
    Join Date
    Mar 2000
    Location
    Stockholm, Sweden
    Posts
    2,342

    Re: Testers wanted ...

    Hi again!

    About the error message, you should press 'details' to see if the error is like 'page fault', 'illegal opcode' or whatever ... it might help me a little to track the bug.

    Hmmm ... while writing the above sentence i realized what i guess is the whole thing. I checked back in my code and found a FEMMS instruction in my inline assembler code which create the flashes. That is bad since it is a 3dnow only instruction and shouldn't execute on your processor, so i guess the error was an 'illegal opcode'. So i replaced it with the equivalent (but slower) MMX standard instruction EMMS ... i guess i will work now.
    I have updated the files above, and included the source code this time.
    I made the water transparent in this release also ...

  6. #6
    Senior Member Regular Contributor
    Join Date
    Feb 2000
    Location
    milano, italy
    Posts
    282

    Re: Testers wanted ...

    ok, now it runs. what a hacked code!

    nice look, however!

    Dolo/\/\ightY
    Dolo/\/\ightY

  7. #7
    Senior Member OpenGL Guru Humus's Avatar
    Join Date
    Mar 2000
    Location
    Stockholm, Sweden
    Posts
    2,342

    Re: Testers wanted ...

    Oki ... great!
    And yes, the code is a liiiiiittle hard to understand some times i guess (and a liiiiittle unorganized and a tiiiiny part of bad programming style now and then ...), especially the assembler parts. I can hardly understand it myself sometimes ... it's been modified, optimized and reorganized to unrecognizeablility ...

  8. #8
    Senior Member Frequent Contributor
    Join Date
    Feb 2000
    Location
    France
    Posts
    880

    Re: Testers wanted ...

    Hi Humus!

    Nice snapshot, but I can not get it to work on my Dual Pentium III 600Mhz 512Mb ELSA Erazor X2 (DDR 32)....

    I forgot : I am running Windows NT 4.0 SP6a which is probably the problem coz' the error message is :

    The exception Privileged instruction.
    (0xc0000096) occurred in the application at location 0x004014e2.

    Click OK.......

    I have compiled your program myself and the privileged instruction is the very first one of your GetMHz() function... Sorry, I know very well Motorola Assemblers (68xxx and DSP 56xxx) but I am not as good with Intel ones !

    Can you fix that ???

    Regards.

    Eric

  9. #9
    Senior Member OpenGL Guru Humus's Avatar
    Join Date
    Mar 2000
    Location
    Stockholm, Sweden
    Posts
    2,342

    Re: Testers wanted ...

    Yes, NT is probably the problem, since it got a lot of restricts of calling the hardware, which i do in the GetMHz function.

    What about if you replace the GetMHz() function with this in your case:

    int GetMHz(){
    return 600;
    }

    Does it work then or is there more problems?

  10. #10
    Senior Member Frequent Contributor
    Join Date
    Feb 2000
    Location
    France
    Posts
    880

    Re: Testers wanted ...

    That is me again !

    Then it seems to work but I am not sure if I can see the rock (is that a rock ? ) properly... Actually, I have the sun coming staight on my screen so the contrast is not quite good at the moment !

    I'll tell you later when the sun is gone (for once we've got sun in the UK and I want it to go... I am gone crazy !).

    Cheers.

    Eric

    P.S. : the fire and the bolt work perfectly and that looks GREAT !

Page 1 of 5 12345 LastLast

Similar Threads

  1. Looking for testers for a OGL 3 Samples Pack
    By imported_Groovounet in forum OpenGL: Linux
    Replies: 6
    Last Post: 12-30-2009, 11:31 PM
  2. Looking for beta testers for new OpenGL software
    By Stefano de Carolis in forum OpenGL: Advanced Coding
    Replies: 2
    Last Post: 05-03-2007, 11:18 PM
  3. Visual Shader Composer looking for testers
    By eirikhm in forum OpenGL: GLSL
    Replies: 6
    Last Post: 06-02-2005, 08:24 AM
  4. Need testers for BlackJack game
    By nexusone in forum OpenGL: Basic Coding
    Replies: 8
    Last Post: 10-26-2002, 08:42 AM
  5. testers for OpenGL Demo wanted ...
    By Diapolo in forum OpenGL: Basic Coding
    Replies: 11
    Last Post: 05-05-2000, 02:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean