Results 1 to 6 of 6

Thread: Bug with cos and sin

  1. #1
    Junior Member Newbie
    Join Date
    Jul 2000
    Location
    Paris, France
    Posts
    5

    Bug with cos and sin

    Hello,

    When I call cos or sin in an
    OpenGL+GLUT program, I get an
    error :
    BUG IN DYNAMIC LINKER: ld.so: dl-version.c : assertion "needed != (void *)()" failed
    (or something like that)
    Can anyone help ?
    Thanks !

  2. #2
    Member Contributor
    Join Date
    Feb 2000
    Location
    Breda, Netherlands
    Posts
    57

    Re: Bug with cos and sin

    That's some nifty error you've created there

    Did you link the math lib with -lm ?

    John

  3. #3
    Member Contributor
    Join Date
    Feb 2000
    Location
    Breda, Netherlands
    Posts
    57

    Re: Bug with cos and sin

    That's some nifty error you've created there

    Did you link the math lib with -lm ?

    John

  4. #4
    Junior Member Newbie
    Join Date
    Jul 2000
    Location
    Paris, France
    Posts
    5

    Re: Bug with cos and sin

    In fact, the bug appears only when
    I have my drivers installed.
    I think that the bug is in the drivers.
    Thanks for having replied !

  5. #5
    Junior Member Newbie
    Join Date
    May 2000
    Posts
    18

    Re: Bug with cos and sin

    I got this same error and I recompiled the source code again and made sure to include the -lm option. My code now runs fine.

  6. #6
    Junior Member Newbie
    Join Date
    May 2000
    Posts
    18

    Re: Bug with cos and sin

    Also i replace my libglut.so with the one that is on the dri.sourceforge.net if you follow the resources think I think the libglut.so that is installed with x has some issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean