Results 1 to 2 of 2

Thread: Troubles with XF86VidModeSwitchModeTo()

  1. #1
    Member Contributor
    Join Date
    Sep 2009
    Posts
    96

    Troubles with XF86VidModeSwitchModeTo()

    Here it is:
    - My desktop resolution is 1024x768
    - I change the resolution to 640x480 with XF86VidModeSwitchToMode function
    - Now I want to retrieve the screen width, I use the DisplayWidth and DisplayHeight functions but they returns me the resollution is 1024x768!! instead of 640x480... Whats happening? There is other way to retrieve the current desktop resollution???
    Thx

  2. #2
    Senior Member Regular Contributor
    Join Date
    Feb 2001
    Location
    Montréal, QC, Canada
    Posts
    304

    Re: Troubles with XF86VidModeSwitchModeTo()

    You get the virtual screen resolution, not the rendered area resolution.
    Check if there was an error returned by XF86VidModeSwitchToMode.

Similar Threads

  1. Troubles with X11 :(
    By animaks in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 07-04-2012, 05:31 AM
  2. MipMapping troubles
    By azcoder in forum OpenGL: Advanced Coding
    Replies: 3
    Last Post: 10-23-2007, 03:03 PM
  3. VBO troubles :-)
    By Ozzy in forum OpenGL: Advanced Coding
    Replies: 18
    Last Post: 07-15-2003, 08:57 AM
  4. big/little-endian troubles
    By Bossa Nova in forum OpenGL: Advanced Coding
    Replies: 6
    Last Post: 01-11-2003, 11:14 AM
  5. 3D Studio MAX Troubles
    By MrShoe in forum OpenGL: Advanced Coding
    Replies: 2
    Last Post: 11-29-2000, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean