Results 1 to 3 of 3

Thread: OpenGL 3.1 object models / backward compatability?

  1. #1
    Junior Member Newbie
    Join Date
    Mar 2006
    Location
    Silverton, Oregon
    Posts
    27

    OpenGL 3.1 object models / backward compatability?

    I have a few questions that are rather concerning to me.

    1) Say that OpenGL 3.1 has the object model everyone has been dying to have, and say it's "cleaned" up. Will it be able to run older OpenGL applications like DOOM 3, etc.?

    2) Say a company has an existing application that gets modified over time but can't make the big clean swap to OpenGL 3.1. Reason is there's nothign that benefits them from using the later features. It may have OpenGL 1.3-2.0 features. Will they most likely still be able to compile it under OpenGL 3.1?

  2. #2
    Senior Member OpenGL Pro Ilian Dinev's Avatar
    Join Date
    Jan 2008
    Location
    Watford, UK
    Posts
    1,294

    Re: OpenGL 3.1 object models / backward compatability?

    1) It would be strange if one day 3.1 is released, and all software that uses OpenGL ceases to function .
    2) as long as you keep your current gl.h and opengl32.lib, what's the problem with compilation? Also, starting to make use of extra 1.3-2.1 features turns into question 1)

  3. #3
    Senior Member Frequent Contributor _NK47's Avatar
    Join Date
    Mar 2008
    Posts
    574

    Re: OpenGL 3.1 object models / backward compatability?

    compatibilty will be left for as long as appropriate. one day (in 10/20 years maybe) you probably need an OpenGL 2 emulator to run Doom3. would not worry about it.

Similar Threads

  1. OpenGl Compatability issues
    By saekalive in forum OpenGL: User Software
    Replies: 1
    Last Post: 10-22-2015, 07:46 AM
  2. OpenGL compatability.
    By in forum OpenGL: User Software
    Replies: 2
    Last Post: 02-23-2004, 02:03 PM
  3. OpenGL and the Myth of DirectX Backward Compatibility
    By prsobel in forum OpenGL: User Software
    Replies: 32
    Last Post: 01-28-2003, 01:13 PM
  4. Backward compatibility: why ???
    By Julien Cayzac in forum OpenGL: General
    Replies: 1
    Last Post: 12-04-2001, 10:38 AM
  5. compatability with older versions on opengl
    By nightshade in forum OpenGL: General
    Replies: 6
    Last Post: 09-09-2001, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean