Results 1 to 9 of 9

Thread: Getting RC for GL 3.0 fails.

  1. #1
    Junior Member Newbie
    Join Date
    Sep 2005
    Posts
    20

    Getting RC for GL 3.0 fails.

    Hi all,
    I have Geforce 9500 GT in a computer with Windows Vista 32 Home basic.

    I installed Forge 181.20. When trying to get a pointer to wglCreateContextAttribsARB using the line:

    PFNWGLCREATECONTEXTATTRIBSARBPROC wglCreateContextAttribsARB = (PFNWGLCREATECONTEXTATTRIBSARBPROC)wglGetProcAddre ss("wglCreateContextAttribsARB");

    I get only 0x0000000000 (after getting the RC of OpenGL 2.1).

    What I can do? why is this failure? thanks.

  2. #2
    Senior Member Regular Contributor
    Join Date
    Mar 2007
    Location
    Latvia
    Posts
    225

    Re: Getting RC for GL 3.0 fails.

    181.20 does not support OpenGL 3.0 without NVemulate. Only 181.00 driver does.

    See here: http://www.geeks3d.com/?p=3033

  3. #3
    Junior Member Newbie
    Join Date
    Sep 2005
    Posts
    20

    Re: Getting RC for GL 3.0 fails.

    Doesn't help. Thanks.

  4. #4

    Re: Getting RC for GL 3.0 fails.

    Hi,

    I have also GeForce 9500GT, and bought it because I wanted to try OpenGL 3.0.

    On my PC wglCreateContextAttribsARB also failed, but then I found out what to do:
    • Create OpenGL "Legacy" context using wglCreateContext
    • Then create OpenGL 3 context using wglCreateContextAttribsARB

    The problem was in fact without created context, wglGetProcAddress("wglCreateContextAttribsARB") always returned 0, which meant it was impossible to obtain context.

    Hope it helps, here it worked with ForceWare 181.2 and enabled GL3 support via NVEmulate.


    Petr

  5. #5
    Junior Member Newbie
    Join Date
    Sep 2005
    Posts
    20

    Re: Getting RC for GL 3.0 fails.

    Hi,
    This is what I tried too, and wglGetProcAddress failed.
    Maybe it is becasue of Window Vista?
    Is it enough in NVEmulate to choose only "Enable OpenGL 3.0/GLSL 1.3 APIs"?

    I think that I will have to put here a full example.
    The class style CS_OWNDC is good or a problem?

    Thanks

  6. #6

    Re: Getting RC for GL 3.0 fails.

    Hi,

    I have Windows XP, SP2 so cannot judge Vista support.
    You can check code skeleton here: http://www.jose.it-berater.org/smffo...p?topic=2976.0

    It is written in PowerBASIC, window creation is done via Win32 API commands with minimum of PB specific tweaks, so you should not get confused.

    If you want, you can PM me with your email address, and I can send you compiled example.

    If it will fail, then I am afraid I have no more advice, as this was my first attempt to work with OpenGL 3.0.

    If it will run, then you know which source to study


    Petr

    P.S. Yes, enabling that single checkbox is enough
    P.P.S. I should have read better your original post to see you did basically the same

  7. #7
    Junior Member Newbie
    Join Date
    Sep 2005
    Posts
    20

    Re: Getting RC for GL 3.0 fails.

    Thanks glPetr! it works!

  8. #8
    Junior Member Newbie
    Join Date
    Sep 2005
    Posts
    20

    Re: Getting RC for GL 3.0 fails.

    My mistake was that I didn't use wglMakeCurrent for the legacy RC.

  9. #9

    Re: Getting RC for GL 3.0 fails.

    I am happy it worked for you, now let the OGL3 fun begins

Similar Threads

  1. vkDestroyDevice fails
    By KudzeLT in forum Vulkan
    Replies: 3
    Last Post: 05-23-2016, 08:33 PM
  2. glReadBuffer fails
    By henniman in forum OpenGL: Advanced Coding
    Replies: 1
    Last Post: 05-05-2010, 02:26 PM
  3. What must be done when glUnmapBufferARB fails ?
    By kettch in forum OpenGL: Advanced Coding
    Replies: 5
    Last Post: 09-04-2008, 06:09 AM
  4. SetPixelFormat Fails
    By gunsboy in forum OpenGL: Basic Coding
    Replies: 3
    Last Post: 11-19-2002, 10:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean