Results 1 to 4 of 4

Thread: problem about install ForceWare 181.00

  1. #1
    Junior Member Newbie
    Join Date
    Jan 2009
    Posts
    5

    problem about install ForceWare 181.00

    hi all,

    i have installed ForceWare 181.00 on my vista 64bit

    but the GPU Caps Viewer still shows that the OpenGL version is 2.1.2

    i really dont know whats wrong with it. or any thing i missed?

    thanks alot!

  2. #2
    Super Moderator OpenGL Lord
    Join Date
    Dec 2003
    Location
    Grenoble - France
    Posts
    5,574

    Re: problem about install ForceWare 181.00

    http://developer.nvidia.com/object/nvemulate.html
    see "Controlling OpenGL 3.0 and GLSL 1.30 Support"

    "With the OpenGL 3.0 / GLSL 1.30 feature set enabled, the driver will export the WGL_ARB_create_context WGL extension string. However, the GL_VERSION string will still show OpenGL 2.1 support. Only when you use the new wglCreateContextAttribsARB() entrypoint to create an OpenGL 3.0 context, then query the version string it will return "OpenGL 3.0"."

  3. #3
    Junior Member Newbie
    Join Date
    Jan 2009
    Posts
    5

    Re: problem about install ForceWare 181.00

    but only before 181.00, nvemulate was needed.
    "Before ForceWare 181.00, we had to use NVemulate to enable OpenGL 3.0 support."
    see http://www.geeks3d.com/?p=2675

  4. #4
    Senior Member Regular Contributor
    Join Date
    Mar 2007
    Location
    Latvia
    Posts
    225

    Re: problem about install ForceWare 181.00

    NVemulate previously allowed to create OpenGL 3.0 context at all.
    181.00 driver allowed to create OpenGL 3.0 context without NVemulate. But anyway - OpenGL version 3.0 is available only when you create OpenGL context in special way (using newly introduced WGL_ARB_create_context). If you use program that does not know this special way (WGL_ARB_create_context extension) and creates context in old way (simply by using only wglCreateContext) then you will not get v3.0 context.

Similar Threads

  1. DOM SVN install - library problem
    By Judd in forum COLLADA
    Replies: 5
    Last Post: 11-01-2007, 06:06 PM
  2. Problem with fragment.color.secondary, specific to Forceware 91.47
    By CoinCoin in forum OpenGL: Advanced Coding
    Replies: 0
    Last Post: 10-17-2006, 01:40 AM
  3. Fedora 5 Nvidia install problem
    By jerryyyyyy in forum OpenGL: Basic Coding
    Replies: 2
    Last Post: 06-12-2006, 10:55 AM
  4. i have problem when i install DX9.0b
    By soum3a81 in forum OpenGL: User Software
    Replies: 0
    Last Post: 11-24-2003, 04:55 AM
  5. Linux install problem
    By zhiw13 in forum OpenGL: Basic Coding
    Replies: 9
    Last Post: 09-28-2003, 04:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean