Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: WebGL doesn't work for me !!!

  1. #11
    Email address no longer exists
    Join Date
    May 2010

    Re: WebGL doesn't work for me !!!

    I tested this on systems with Intel cards and software rendering worked, and on a Linux box with a Nvidia card the sw/hw switch worked all right - as I recall, there's a chance I just forgot, will check later, as now I am out for a week or so, hang gliding

  2. #12
    Senior Member
    Join Date
    May 2010

    Re: WebGL doesn't work for me !!!

    Quote Originally Posted by giles
    Interesting. Do you have an Intel or other non-OpenGL-compatible graphics card? I have the impression that it ignores the software rendering toggle if you have working OpenGL drivers; I certainly can't persuade it to do software rendering on any of my machines.
    That would be a problem. Most (if not all) Intel chipsets only support OpenGL 1.2. So if the system is refusing to go into software rendering because there is a "working OpenGL driver" then that's a problem because you can run WebGL on top of OpenGL 1.2 because (aside from anything else) it doesn't support shaders.

    Your best chance of getting it working is to use Direct3D via ANGLE. However, I've found that this doesn't work on the older Intel chipsets...despite them claiming to have DX9 support. They don't run any of the DX9 applications I've written - so if they do run DX9, it's in some really minimalistic way. I tried - and eventually gave up on, getting WebGL to run on my wife's old Dell desktop that has a 3000-series Intel chip.

    So I'm pretty sure that the Intel GMA X3100 won't run WebGL in hardware at all...and if having an OpenGL 1.2 driver stops it from falling back on software rendering - you may be completely screwed with software rendering too.

    My son's Win7 EeePC netbook has a newer (but still pretty crappy) Intel chip - it runs WebGL in Direct3D/ANGLE using Chrome and gets poor-but-bearable frame rates on our fairly complex WebGL application so long as you keep the canvas size fairly small and don't throw too much geometry at it. It doesn't work with FireFox/Minefield - although I expect that to get fixed when Minefield starts using ANGLE.

  3. #13

    Re: WebGL doesn't work for me !!!

    Google Chrome version 10.0.648.127 (Official Build 76697):Win XP:
    WebGL does not work after I upgraded to Chrome 10.
    Any others with the same problem?

  4. #14
    Junior Member
    Join Date
    Sep 2011

    Re: WebGL doesn't work for me !!!

Page 2 of 2 FirstFirst 12

Similar Threads

  1. GPU_MAX_HEAP_SIZE doesn't work
    By luizdrumond in forum OpenCL
    Replies: 0
    Last Post: 04-14-2013, 03:33 PM
  2. About glGetFloatv(). Why it doesn't work?
    By Ilya in forum OpenGL ES
    Replies: 1
    Last Post: 07-04-2008, 03:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Proudly hosted by Digital Ocean