Results 1 to 2 of 2

Thread: Not rendering good texture

  1. #1
    Junior Member Newbie
    Join Date
    Apr 2011
    Posts
    3

    Not rendering good texture

    Hi!

    This is my code: http://pastebin.com/fZHCnj4h

    I am going to render some texture using `multitexturing`* and got problem:

    I am calling glUniform with a parameter 1, but it's something wrong: OpenGL renders GL_TEXTURE0 (`img` instead of `img2`)... What's wrong with that code? What to change in it?

    *In fact I'm using only the second texture now, but in another shader I can use the first, so because of it I use two textures.

  2. #2
    Junior Member Newbie
    Join Date
    Apr 2011
    Posts
    3

    Re: Not rendering good texture

    Solved; didn't call gluseProgram(program); Thanks.

Similar Threads

  1. Replies: 1
    Last Post: 11-07-2016, 01:17 AM
  2. Some good practices for Vulkan rendering
    By qnoper in forum Vulkan
    Replies: 4
    Last Post: 03-09-2016, 07:47 AM
  3. Good text rendering library
    By A-77X7 in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 09-28-2014, 04:54 AM
  4. is there any good idea for 3D rendering?[Talk]
    By edison in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 04-04-2012, 07:46 PM
  5. Is OpenGL good at Volumn Rendering?
    By Dong in forum OpenGL: Basic Coding
    Replies: 1
    Last Post: 06-19-2000, 07:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean