Results 1 to 3 of 3

Thread: Problems moving from Loaded state to Idle

  1. #1
    Junior Member
    Join Date
    Oct 2011

    Problems moving from Loaded state to Idle

    Hello, i'm trying to use Tegra hardware to decode h.264 in an android environment.

    I dlopened "/system/lib/" on asus transformer.

    I've been struggling with moving from Loaded state into Idle, with no success so far :/

    The "OMX_SendCommand(decoder_handle, OMX_CommandStateSet, OMX_StateIdle, 0)" itself returns fine, but very soon later the callback event handler is then called with Error event of type OMX_ErrorInsufficientResources.

    (And i never really move into Idle state...)

    What are the first things i need to look for ?

    I tried using OMX_AllocateBuffer for both input and output files,
    I also tried using OMX_UseBuffer instead.

    Searching for solutions, i noticed chromium code for their
    Where in some part they set fake buffers, just in order to move from Loaded to Idle state.

    Here's the comment they have there:
    "// Fill the component with fake output buffers. This seems to be required for
    // the component to move from Loaded to Idle. How bogus."

    I tried that and it didn't work either.

    Here's a link to my code:

    Hopefully my error will be more obvious to an expert in using OpenMAX IL.

    Please help me with this one, starting to go crazy here...

  2. #2
    Junior Member
    Join Date
    Oct 2011

    Re: Problems moving from Loaded state to Idle

    I have the same problem.
    Its because of OpenMax IL needs system privilege.
    But the android app doesn't have it

    So the error is shown OMX_ErrorInsufficientResources.

    I Can go to loaded state to Idle in Android Shell (as su in console)
    but with app it doesn't..

    Looking for a solution for it.. How to get system privilege for android app? or any other workaround?

  3. #3
    Junior Member
    Join Date
    Oct 2011

    Re: Problems moving from Loaded state to Idle

    Thanks for the reply!

    System privileges is quite tricky to get (for a non custom android build...)

    Strangely it does work for me on android 2.x on Motorola ATRIX 4G,
    so i assume it's a change that started in 3.x for tablets.

Similar Threads

  1. Is there maximum amount of loaded kernels?
    By Kallex in forum OpenCL
    Replies: 2
    Last Post: 07-28-2011, 12:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Proudly hosted by Digital Ocean