Results 1 to 2 of 2

Thread: Why complier error?

  1. #1
    Newbie Newbie
    Join Date
    Jun 2014
    Posts
    1

    Why complier error?

    My computer is mbp ox 10.9.
    I try my first opengl and try https://www.youtube.com/watch?v=SAmD_Aq1Un4.
    But I meet error message.
    About blew
    warning: 'glutInit' is deprecated: first deprecated in OX X 10.9 (glutInit(&argc, argv))

    Who can teach me ? How to find solve?

  2. #2
    Senior Member Regular Contributor Agent D's Avatar
    Join Date
    Sep 2011
    Location
    Innsbruck, Austria
    Posts
    281
    That's not a compiler error, it's a warning.

    It basically says that glut is deprecated and should not be used in new programs.

    I guess that the developers at Apple would prefere you to use their system API instead of glut.

Similar Threads

  1. Shader Compile Error: ERROR: 0:1: '' : syntax error #version
    By Blakeasd in forum OpenGL: Basic Coding
    Replies: 12
    Last Post: 07-25-2013, 07:35 PM
  2. ERROR: 0:17:'f' : syntax error parse error
    By hopeless in forum OpenGL: GLSL
    Replies: 1
    Last Post: 08-23-2010, 01:05 PM
  3. Replies: 1
    Last Post: 09-24-2007, 04:02 AM
  4. Replies: 3
    Last Post: 02-07-2003, 05:06 AM
  5. what language/complier's easiest/best for openGL ?
    By in forum OpenGL: Basic Coding
    Replies: 8
    Last Post: 01-29-2001, 05:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean