Results 1 to 2 of 2

Thread: Texture disappears at edge of v

  1. #1
    Newbie Newbie
    Join Date
    Jun 2016
    Posts
    2

    Texture disappears at edge of v

    I'm working on a 2D asteroids game (in Windows) and have added textures to the sprites. They work fine except at the left and top edges of the window. The texture is missing until the sprite moves completely onto the screen. This doesn't happen at the right or bottom edge. The sprites are polygons and I'm using a gluOrtho2D projection.

  2. #2
    Newbie Newbie
    Join Date
    Jun 2016
    Posts
    2

    Red face Solved

    OK, found my error. I wasn't re-enabling textures when redrawing the sprites that straddle an edge.

Similar Threads

  1. Edge texture filtering
    By Aleksandar in forum OpenGL: Advanced Coding
    Replies: 13
    Last Post: 09-21-2013, 09:18 AM
  2. Texture disappears!
    By nrst87 in forum OpenGL: Advanced Coding
    Replies: 2
    Last Post: 03-13-2012, 05:20 PM
  3. Avoid sampling at the texture Edge?
    By HanWu in forum OpenGL: Advanced Coding
    Replies: 7
    Last Post: 12-18-2010, 05:45 PM
  4. Texture has white dot line edge!
    By imported_davie in forum OpenGL: Basic Coding
    Replies: 6
    Last Post: 07-23-2010, 06:39 AM
  5. Texture edge problem
    By in forum OpenGL: Basic Coding
    Replies: 0
    Last Post: 11-26-2002, 04:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Proudly hosted by Digital Ocean