Problem: Attempting to share a Renderbuffer (or a Texture) fails when clSetKernelArg() is called.

I've spent days on this and am finally asking for help.

My program generates frames for a video projector that runs at 60fps (16.7ms frames).

My kernel runs in (typically) 24ms, but it's taking 50ms between each frame. I assume that some of the extra cost is because I'm using the GPU to calculate the pixels, then enqueuing a readbuffer to pull the data *off* the GPU, then using glDrawPixels to put it *back onto* the GPU for display. Perfect situation to try OpenGL/OpenCL interoperation, right?, to avoid the two extra copy operations.

There are many examples, and I *have* succeeded in sharing a VBO with OpenCL, and can write to it, but that doesn't help me. I don't want to write vertex data, just the 2-D image that's been calculated.

There are examples of two different ways to do this, and they both involve Framebuffer objects.

You can attach a Renderbuffer to a Framebuffer, or you can attach a Texture to a Framebuffer.

Then you should be able to write to that buffer in opencl and display it with opengl, no extra copies.

I have found a few examples of this in code, and I think I'm doing everything exactly the way the examples say to do it, but maybe it is broken in OSX? .. because it doesn't work. The FBO is "Complete", no errors along the way, until I try to do the clSetKernelArg. That call returns error -38, CL_INVALID_MEM_OBJECT.

*note: I would rather use a Renderbuffer than a Texture, since all I'm doing is making a 2-D RGB image that I want to display. But I tried a Texture out of desperation. Still no help.

I do these steps, in this order, with some other stuff in between:

kCGLContext = CGLGetCurrentContext();
kCGLShareGroup = CGLGetShareGroup( kCGLContext );

glGenFramebuffers( 1, &fboid );
glBindFramebuffer( GL_FRAMEBUFFER, fboid );

glGenRenderbuffers( 1, &rboid );
glBindRenderbuffer( GL_RENDERBUFFER, rboid );
glRenderbufferStorage( GL_RENDERBUFFER, GL_RGBA, rb_wid, rb_hgt );

glboid = rboid;



cl_context_properties ourprops[] = { CL_CONTEXT_PROPERTY_USE_CGL_SHAREGROUP_APPLE, (cl_context_properties)kCGLShareGroup, 0 };

contextZ = clCreateContext( ourprops, 1, &dev_idZ[0], clLogMessagesToStdoutAPPLE, NULL, &err );

clbo = clCreateFromGLRenderbuffer( contextZ, CL_MEM_WRITE_ONLY, glboid, &err );

then later:

err = clSetKernelArg( kernelZ, 1, sizeof(cl_mem), &clbo );

... which fails with error -38, CL_INVALID_MEM_OBJECT.


(I've tried adding a second Renderbuffer and attaching it to a Depth Attachment Point, in case that was needed. No help.)

(I've tried the same thing with a Texture bound to the FBO, and I get the same error in the same place.)

... does anybody have any ideas at all?