Results 1 to 4 of 4

Thread: Getting an error code of -1001

  1. #1

    Getting an error code of -1001

    Hello OpenCL programmers,
    I am using Visual Studio 2010 for coding in OpenCL. When I run the following program, I am getting an error code of -1001 and no. of platforms as 0. I have installed AMD APP SDK 2.9 in my system. I have an Intel Dual Core CPU but no GPU.

    #include "CL/cl.h"
    #include <stdio.h>

    int main()
    cl_platform_id pid;
    cl_uint num;
    cl_uint n=1;
    cl_int error=clGetPlatformIDs(1,&pid,&num);
    printf("Error code= %d\nNo. of platforms= %d",error,num);

    Please help. Thanks in advance.

  2. #2
    Senior Member
    Join Date
    Oct 2012
    You have to install an OpenCL driver for a supported device. Since you have an Intel CPU but no GPU, you should install the Intel OpenCL driver instead.

  3. #3
    It worked. Thanks a lot. I was stuck there for a long time.

  4. #4
    Join Date
    Apr 2014
    I have an identical error code with a different OS and set of hardware. I do not know if that constitutes a different thread.
    I have an Nvidia GPU and an AMD 8 core CPU. running on Debian AMD-64. nvidia.icd is located in /etc/OpenCL/vendors
    OpenGL has been running successfully on this machine, but I have not gotten past "Hello World" in OpenCL.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Proudly hosted by Digital Ocean